使用过程中遇到问题,欢迎到 网络跳越论坛 或 tg群组https://t.me/hijkclub 交流,或关注Youtube频道:网络跳越

2020.10.26更新:建议使用 V2ray多合一脚本,支持VMESS+websocket+TLS+Nginx、VLESS+TCP+XTLS、VLESS+TCP+TLS等组合

应网友请求,今天完成了Ubuntu版的v2ray带伪装一键安装脚本(仅支持Ubuntu 16.04 LTS及以上版本),目前已经上传到 Github。CentOS系统请参考: v2ray带伪装一键脚本

提示:这是自己搭建科学上网环境的第三步,请确认已经做了前两步:

  1. 购买服务器和域名。想服务器速度快请参考 搬瓦工购买服务器详细教程购买AkkoCloud德国、美西CN2 GIA VPS ,想ip被封后免费换请参考:购买vultr服务器超详细图文教程,购买域名可参考:Namesilo购买域名详细教程
  2. 连接到服务器。Windows系统请参考 Bitvise连接Linux服务器教程,mac用户请参考 Mac电脑连接Linux教程

伪装的前提是需要一个域名(例如hijk.pw),并且域名的某个主机名(例如hijk.art)正确解析到服务器的ip!如果你没有域名,请使用常规版的一键脚本:v2ray一键脚本Ubuntu版

注意:

1. 如果服务器已经有运行网站,请联系网站运维再执行脚本,否则可能导致原来网站无法访问,本人不负责!

2. 对域名没有要求,不管国内还是国外注册的都可以,不需要备案,不会影响使用,也不会带来安全/隐私上的问题;

3. 根据 Namesilo购买域名详细教程 购买的域名,默认@和www在买之前都已经做了解析,因此尽管www已经改成了你服务器的ip,但执行本脚本时可能还会出现“主机未解析到当前服务器IP”的错误。这时只需要换个名称做解析即可,例如 www2。

4. 如果想上cdn,请根据本教程操作完后再参考:v2ray使用cloudflare中转流量,拯救被墙ip

5. 理论上只要流量够、服务器扛得住,同一个配置支持无数人、无限设备使用。如果想为不同的人配置不同的id,请参考:v2ray多用户配置

6. 2020.3.2月更新:脚本已支持更换Nginx的https端口(默认443)。如非443端口被墙或特殊原因,请使用443端口!

7. 安装魔改BBR/BBR Plus/锐速清参考:安装魔改BBR/BBR Plus/锐速(Lotserver)

8. 搭建好伪装v2ray后建站/改伪装网站请参考:v2ray伪装建站教程

9. 这两天官方脚本会出现“unzip: cannot find zipfile directory in one of /tmp/v2ray/v2ray.zip or /tmp/v2ray/v2ray.zip.zip, and cannot find /tmp/v2ray/v2ray.zip.ZIP, period. Failed to copy V2Ray binary and resources.”的抽风现象,本站一键脚本已经做了兼容修复;

10. 近日v2ray爆出tls流量识别漏洞,建议客户端勾选“allowinsecureciphers”,小火箭、clash等客户端不受影响;

11. 刚搭建好带伪装的v2ray不要猛上流量,否则可能导致被限速、端口被墙,严重可能ip被墙。

使用教程

1. 如果vps运营商默认开启了防火墙(阿里云、google云等默认开启,搬瓦工/hostdare/vultr默认放行所有端口),请先登录vps管理后台放行80和443端口,否则可能无法正确获得证书导致脚本失败;

2. 登录到服务器(windows请参考 Bitvise连接Linux服务器教程,mac用户请参考 Mac电脑连接Linux教程),在终端(黑框框)输入如下命令:

bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/ubuntu_install_v2ray2.sh)

按回车键,屏幕上开始滚动各种看得懂看不懂的东西。紧盯着屏幕,直到屏幕出现“确认满足按y,按其他退出脚本:”,确认条件满足,按y回车,然后输入你域名的主机名(注意是主机名,比如hijk.art,最好不要填裸域名hijk.pw!),以及设置一个伪装路径(不能是/),例如/abcedf(强烈建议设置一个复杂的、别人猜不到的路径,除 “数字、字母、/、-、_” 外不能有其他特殊字符!)。

接下来脚本会自动疯狂运行,直到屏幕上出现安装成功的提示。如果安装过程卡住,请耐心等待几分钟;如果期间网络断开(windows上表现为黑框框中或者顶部标题出现disconnected字样,mac表现为终端出现“closed by remote host”或”broken pipe”),请重新连接后再次执行命令。脚本运行成功会输出配置信息,截图如下:

v2ray运行状态信息

v2ray运行状态信息

到此服务端配置完毕,服务器可能会自动重启,windows终端出现“disconnected”,mac出现“closed by remote host”说明服务器成功重启了,如果没提示重启则不需要

可能出现的问题

1. 多次运行一键脚本,安装过程中会出现如下提示:

What would you like to do?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: Keep the existing certificate for now
2: Renew & replace the cert (limit ~5 per 7 days)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press 'c' to cancel):

输入1,回车即可。

2. 如果提示证书失败,终端出现如下提示:

An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains:test2.hijk.pw: see https://letsencrypt.org/docs/rate-limits/

说明这个主机名近期申请过太多次免费证书,请换一个主机名尝试,例如test2.hijk.pw 换成 test3.hijk.pw(需要到dns控制台添加解析)。

如何判断服务端已经正常运行?

操作如下:

1. 浏览器输入域名,打开是一个随机小说网站。注意:小说网站是本人在网上随机找的,如果出现下面的错误也是正常的:

小说网站错误截图

小说网站错误截图

2. 输入域名加伪装路径(例如https://hijk.art/abcdef),出现”bad request”。

只要有第2个现象,说明服务端运行正常,不用管直接打开域名是小说网站还是其他提示

客户端下载

接下来是科学上网最后一步:下载客户端,并参考页面中的配置教程进行配置:

v2ray windows客户端下载

v2ray安卓客户端下载

v2ray mac客户端下载

v2ray ios客户端下载

下载客户端配置好后,就可以愉快的上外网了!

其他

1. 查看v2ray运行状态/配置:bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/ubuntu_install_v2ray2.sh) info

2. v2ray管理命令:启动:systemctl start v2ray,停止:systemctl stop v2ray,重启:systemctl restart v2ray

3. nginx管理命令:测试配置文件有无错误:nginx -t,启动:systemctl start nginx,停止:systemct stop nginx,重启:systemctl restart nginx

4. 查看SSL证书:certbot certificates,更新证书:systemctl stop nginx; certbot renew; systemctl restart nginx

5. 更新v2ray到最新版:bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/goV2.sh)(提示“装不上daemon”不用管,systemctl restart v2ray重新启动v2ray就好了)

6. 卸载命令: bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/ubuntu_install_v2ray2.sh) uninstall

7. 建站/改伪装网站请参考:v2ray伪装建站教程

参考

1. v2ray高级技巧:流量伪装

2. v2ray一键脚本

3. trojan一键脚本


346 条评论

头像

棉签 · 2020年3月8日 15:06

请问ubuntu的v2ray带伪装一键脚本有设置开机自启动v2ray吗?有的时候想重启主机。

    跳越者

    跳越者 · 2020年3月8日 15:07

    设置了,随便重启

头像

John · 2020年3月8日 03:36

您好,请问使用v2ray带伪装一键安装脚本安装完成之后还需要安装bbr或者是bbr plus么?因为我用speedtest跑速度的时候速度真有点慢

    跳越者

    跳越者 · 2020年3月8日 09:12

    已经安装bbr了,想要换其他的得自己装

头像

王光卫博客 · 2020年3月7日 14:19

这种文章必须保存收藏

头像

phoenix · 2020年3月5日 19:10

安装成功,但请教下如何生成客户端的VMESSS码?找了网上的生成器,里面要填证书相关的内容,因不知道怎么填,也无果 :(

    跳越者

    跳越者 · 2020年3月5日 19:17

    最简单的就是先在客户端配置好,客户端就能生成

头像

ren · 2020年3月5日 01:16

TypeError: from_buffer() cannot return the address of the raw string within a bytes or unicode or bytearray object
获取证书失败,请到 https://hijk.art 反馈

头像

ren · 2020年3月5日 01:10

获取证书失败

    跳越者

    跳越者 · 2020年3月5日 01:11

    到论坛发帖,贴上错误信息截图

      头像

      ren · 2020年3月5日 01:17

      论坛在哪里?

        跳越者

        跳越者 · 2020年3月5日 01:21

        看文章最上面的信息

          头像

          ren · 2020年3月5日 01:23

          gege.我打不开那个论坛。不知道为何。

          头像

          ren · 2020年3月5日 01:28

          File “/usr/local/lib/python3.5/dist-packages/josepy/util.py”, line 7, in
          import OpenSSL
          File “/usr/local/lib/python3.5/dist-packages/OpenSSL/__init__.py”, line 8, in
          from OpenSSL import crypto, SSL
          File “/usr/local/lib/python3.5/dist-packages/OpenSSL/crypto.py”, line 15, in
          from OpenSSL._util import (
          File “/usr/local/lib/python3.5/dist-packages/OpenSSL/_util.py”, line 152, in
          with ffi.from_buffer(b””):
          TypeError: from_buffer() cannot return the address of the raw string within a bytes or unicode or bytearray object
          获取证书失败,请到 https://hijk.art 反馈

          跳越者

          跳越者 · 2020年3月5日 01:29

          重启服务器试试

          头像

          ren · 2020年3月5日 01:37

          不行测试了,重启后依旧。

          跳越者

          跳越者 · 2020年3月5日 01:40

          如果可以,建议重新安装最新版系统

          头像

          ren · 2020年3月5日 01:40

          前几天我第一次安装成功过。但是当时那个伪装路径搞的有符号,我卸载了,就再也没有成功过。
          但是我不断的更换了好多域名依旧无效。

          我用的AWS的VPS。

          头像

          ren · 2020年3月5日 01:42

          可以肯定不是系统的问题,因为我装这个前刚重装的系统,新的系统安装的这个。我觉的好像和我的VPS有关。
          我的VPS,外网IP是A,内网IP是B。
          我登录服务器后一直显示的都是我的内网IP,好像我的内网IP并没有变过。
          我估计是不是记录我这台IP安装过。

          跳越者

          跳越者 · 2020年3月5日 01:44

          ip没问题

          pip3 uninstall certbot,然后再运行一键脚本试试

          头像

          ren · 2020年3月5日 01:52

          本脚本为带伪装的一键脚本,运行之前请确认如下条件已经具备:
          1. 一个域名
          2. 域名的某个主机名解析指向当前服务器ip(18.163.122.106)

          确认满足按y,按其他退出脚本:y
          请输入您的主机名:ren.sandiancn.com
          请输入伪装路径,以/开头:/ren
          请输入Nginx端口[100-65535的一个数字,默认443]:

          这里我按回车不输入,没问题吧?

          头像

          ren · 2020年3月5日 01:56

          v2ray运行状态:正在运行
          v2ray配置文件:/etc/v2ray/config.json
          nginx运行状态:已停止
          nginx配置文件:/etc/nginx/conf.d/ren.sandiancn.com.conf

          难倒是因为我没有安装NGINX?

          跳越者

          跳越者 · 2020年3月5日 05:36

          你用netstat -nltp |grep nginx看看有没有

头像

sunrise · 2020年3月3日 20:47

2020/03/03 20:46:06 tcp:127.0.0.1:50824 accepted tcp:activity.windows.com:443 [proxy]
2020/03/03 20:46:06 tcp:127.0.0.1:50825 accepted tcp:beacons5.gvt3.com:443 [proxy]
2020/03/03 20:46:07 [Warning] failed to handler mux client connection > v2ray.com/core/proxy/vmess/outbound: connection ends > v2ray.com/core/proxy/vmess/outbound: failed to read header > v2ray.com/core/proxy/vmess/encoding: failed to read response header > websocket: close 1000 (normal)

我使用V2的时候,连接不上web,应用底下那个框,一直重复显示这些,是什么原因吗?

    头像

    sunrise · 2020年3月3日 20:49

    这是我配置的,同端口不同ID,这是新配的就连不上web,以前配的就可以连接

      跳跃者

      跳跃者 · 2020年3月3日 20:58

      要么服务端没有重启生效,要么客户端配置错了

      头像

      sunrise · 2020年3月3日 21:10

      谢谢,是我没有重启的原因

头像

lost · 2020年3月3日 18:42

报一个bug,检测端口不够鲁棒,我用的是8079端口。。。
其他进程占用了80或443端口,请先关闭再运行一键脚本
端口占用信息如下:
tcp 0 0 0.0.0.0:8079 0.0.0.0:* LISTEN 8798/python

    跳跃者

    跳跃者 · 2020年3月3日 18:48

    好的,谢谢

头像

Frozen · 2020年3月3日 11:03

我配置完连接之后 浏览器提示了错误是ERR_SSL_PROTOCAL_ERROR 这个怎么解决?

    跳跃者

    跳跃者 · 2020年3月3日 11:31

    这个没遇到过,发截图到我的邮箱[email protected]

      头像

      Frozen · 2020年3月3日 12:04

      已发,我用的是shadowrocket,

头像

qrpucp · 2020年3月2日 10:57

您好!很感谢您的教程~
我想请问一下,如果我自己给VPS搭建web环境,然后再使用您的不带伪装的v2ray脚本,那这样是不是和带伪装的脚本效果相同?
如果传输协议等不同的话,那怎么样能把一键脚本安装的web环境更改成自己的web环境呢?

头像

LyXck · 2020年3月1日 22:15

带伪装的 速度只有 0.09M/s 有什么解决方法吗

    跳跃者

    跳跃者 · 2020年3月1日 22:57

    用的v2rayN客户端?试试把域名策略改成asis

      头像

      LyXck · 2020年3月2日 10:16

      试了一下,速度还是一样的。
      我又用新的VPS 搭建了一个,刚开始一个小时速度1M多, 之后速度又变成了0.05M,这是被墙了吗?(带伪装)
      谢谢大佬解答~

        跳跃者

        跳跃者 · 2020年3月2日 10:33

        可能就是被qos限速了

          头像

          LyXck · 2020年3月2日 11:42

          应该是的 , 过几天不用 速度会回来,用了几分钟,速度又不行了。大佬有什么解决方法或者思路吗?

头像

sean · 2020年2月27日 21:16

Ubuntu 16.04 x86 安装初心这个报错 恳请大佬看看
Successfully built zope.component configobj ConfigArgParse parsedatetime
Failed to build cryptography
ERROR: Could not build wheels for cryptography which use PEP 517 and cannot be installed directly
/dev/fd/63: line 187: certbot: command not found

    跳跃者

    跳跃者 · 2020年2月27日 21:23

    这个是pip包版本问题,如果方便,建议用18.04系统,否则需要手工调,麻烦一点

头像

lunng · 2020年2月27日 18:22

请问这个如何解决?谢谢

TypeError: from_buffer() cannot return the address of the raw string within a bytes or unicode or bytearray object
获取证书失败,请到 https://hijk.art 反馈

    头像

    lunng · 2020年2月27日 18:26

    谢谢,看到了相同的问题,我再看看

    跳跃者

    跳跃者 · 2020年2月27日 19:08

    重启服务器再试试

      头像

      rocky · 2020年2月28日 01:16

      同样的问题,重启无用

        跳跃者

        跳跃者 · 2020年2月28日 09:06

        总最新版系统是最简单的解决办法

头像

· 2020年2月24日 12:12

全部安装完毕但是安卓端能链接测试就是失败。这是怎么回事?难道我安卓端配置错误?

    跳跃者

    跳跃者 · 2020年2月24日 12:18

    完全有可能啊

      头像

      · 2020年2月24日 12:32

      首先谢谢你。然后我是完全按照你的指示配置的。我现在很郁闷啊 搞了一天了。求帮助。感谢

        头像

        · 2020年2月24日 12:51

        失败:context deadline exceeded

          跳跃者

          跳跃者 · 2020年2月24日 15:12

          ubuntu版本?有错误信息的上下文吗?

      头像

      · 2020年2月25日 13:50

      服务器那边完全正常 一切OK 就是安卓客户端这边能连上 测试都是失败 也是哪找你的教程设置的。郁闷了

头像

covey · 2020年2月24日 10:20

failed to find an available destination >
可以ping通,是端口封了么?怎么换端口

    跳跃者

    跳跃者 · 2020年2月24日 10:32

    这不能说明封了,可能是配置错了

头像

aiz · 2020年2月24日 05:16

你好,v2ray怎么配置多用户

    跳跃者

    跳跃者 · 2020年2月24日 09:09

    编辑v2ray 的配置文件

      头像

      ljw · 2020年3月2日 15:36

      老哥,我发现ubuntu 18 cryptoggraphy2.14模块 cd /usr/lib/python3/dist-packages;
      rm -r cryptoggraphy cryptography-2.1.4.egg-info
      pip3 uninstall cryptography不能起作用

        跳跃者

        跳跃者 · 2020年3月2日 15:39

        原来这样啊,我一直没找到有这个版本的系统,谢谢你提供的反馈!

      头像

      ljw · 2020年3月2日 15:37

      我是说需要改成上面的,谢谢老哥的脚本

        跳跃者

        跳跃者 · 2020年3月2日 15:40

        非常感谢

头像

UC · 2020年2月23日 13:08

An unexpected error occurred:
pkg_resources.ContextualVersionConflict: (cryptography 2.1.4 (/usr/lib/python3/dist-packages), Requirement.parse(‘cryptography>=2.8’), {‘PyOpenSSL’})

    头像

    UC · 2020年2月23日 13:12

    搬瓦工的vps,系统:Ubuntu 18.04 x86_64

      跳跃者

      跳跃者 · 2020年2月23日 13:19

      先运行这个命令:apt remove -y PyOpenSSL,然后再运行一键脚本

        头像

        UC · 2020年2月23日 14:15

        运行之后还是会出现
        An unexpected error occurred:
        pkg_resources.ContextualVersionConflict: (cryptography 2.1.4 (/usr/lib/python3/dist-packages), Requirement.parse(‘cryptography>=2.8’), {‘PyOpenSSL’})
        Please see the logfile ‘/tmp/tmpgwymdbn1/log’ for more details.
        获取证书失败,请到 https://hijk.art 反馈

          头像

          UC · 2020年2月23日 14:16

          运行apt remove -y PyOpenSSL会出现
          E: Unable to locate package PyOpenSSL

          跳跃者

          跳跃者 · 2020年2月23日 14:19

          先运行:pip3 remove PyOpenSSL,然后再试试?

          之前有人也碰到过这个问题,不过都是ubuntu 16.04,Ubuntu 18.04你这是第一次反馈

          头像

          UC · 2020年2月23日 14:23

          显示
          ERROR: unknown command “remove”

          跳跃者

          跳跃者 · 2020年2月23日 14:29

          pip3 uninstall PyOpenSSL

          头像

          UC · 2020年2月23日 14:39

          ERROR: pyopenssl 19.1.0 has requirement cryptography>=2.8, but you’ll have cryptography 2.1.4 which is incompatible.
          Installing collected packages: PyOpenSSL
          Successfully installed PyOpenSSL-19.1.0
          An unexpected error occurred:
          pkg_resources.ContextualVersionConflict: (cryptography 2.1.4 (/usr/lib/python3/dist-packages), Requirement.parse(‘cryptography>=2.8’), {‘PyOpenSSL’})
          Please see the logfile ‘/tmp/tmpicynwdzy/log’ for more details.
          获取证书失败,请到 https://hijk.art 反馈

          跳跃者

          跳跃者 · 2020年2月23日 14:47

          确定你的系统是Ubuntu 18.04?

          再试试这个:pip3 remove cryptography; pip3 install cryptography,执行完再试试一键脚本

          头像

          UC · 2020年2月23日 15:06

          我把搬瓦工的系统改成centos,然后用centos的脚本安装成功了,谢谢大佬

          跳跃者

          跳跃者 · 2020年2月23日 15:22

          这是最简单的办法😄

头像

hunter · 2020年2月22日 03:24

nginx启动失败!
nginx: [warn] invalid value “TLSv1.3”

大侠,这个怎么处理?

    跳跃者

    跳跃者 · 2020年2月22日 09:42

    nginx的版本太旧了
    我改了脚本,再运行一下吧

头像

零点 · 2020年2月19日 16:00

E: Could not get lock /var/lib/dpkg/lock-frontend – open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
Failed to stop nginx.service: Unit nginx.service not loaded.
E: Could not get lock /var/lib/dpkg/lock-frontend – open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
pip3安装失败,请到 https://hijk.art 反馈

亚马逊的 Canonical, Ubuntu, 18.04 LTS, amd64 bionic image build on 2020-01-12

    跳跃者

    跳跃者 · 2020年2月19日 16:59

    rm -rf /var/lib/dpkg/lock-frontend,然后再试一次

      头像

      零点 · 2020年2月20日 15:25

      还是不行,一样的提示

        跳跃者

        跳跃者 · 2020年2月20日 16:00

        你这个不是脚本的问题,而是你系统软件包的问题,你要上网查查先解决这个,然后再用一键脚本

头像

yang yang · 2020年2月19日 12:28

打算和trojan搭配使用,先安装了Trojan后已完美翻出去,现在安装你这脚本出现端口443被占用的v2ray安装成功!
/dev/fd/63: line 280: ufw: command not found
/dev/fd/63: line 282: ufw: command not found
/dev/fd/63: line 283: ufw: command not found
Reading package lists… Done
Building dependency tree
Reading state information… Done
nginx is already the newest version (1.14.0-0ubuntu1.7).
0 upgraded, 0 newly installed, 0 to remove and 127 not upgraded.
其他进程占用了80或443端口,请先关闭再运行一键脚本
端口占用信息如下:
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 457/trojan
请教有什么办法能够让他两都能安装和谐相处呢?

    跳跃者

    跳跃者 · 2020年2月19日 12:58

    你这个需要手动操作,不适合用一键脚本

      头像

      yang yang · 2020年2月19日 14:06

      请教哪里有手动操作的教程呢?谢谢您啦

        跳跃者

        跳跃者 · 2020年2月19日 14:23

        那你只能看大神写的原理篇:V2Ray高级技巧:流量伪装,脚本基本上按照大神的教程思路写的

          头像

          yang+yang · 2020年2月19日 20:31

          三克油!!谢谢你,我去研究一下

头像

零比玖 · 2020年2月19日 11:51

not found: 3(NXDOMAIN)
主机未解析到当前服务器IP

    跳跃者

    跳跃者 · 2020年2月19日 12:00

    自己ping一下域名,看看ip有没有,是不是你服务器的ip

头像

keiseikami · 2020年2月18日 23:40

您好,请问我是在vultr jp安装的v2ray 去年一直很舒服 速度比较快 移动的宽带 看youtube 可以40000到50000左右的kbps 但是最近3个月就只有1000kbps了 即使用了bbr plus也是这样的速度。。。 用的是ws传输协议 不知道是不是需要换vps 但是vultr真的很人性化有些舍不得 不知道跳跃者用vultr 搭建的v2ray速度怎么样?有没有提高速度的方法?

    跳跃者

    跳跃者 · 2020年2月19日 00:08

    我是移动的,用东京的看很快,装了bbr,没做其他优化

头像

john · 2020年2月15日 21:16

ERROR: pyopenssl 19.1.0 has requirement cryptography>=2.8, but you’ll have cryptography 2.1.4 which is incompatible.
An unexpected error occurred:
pkg_resources.ContextualVersionConflict: (cryptography 2.1.4 (/usr/lib/python3/dist-packages), Requirement.parse(‘cryptography>=2.8’), {‘PyOpenSSL’, ‘pyOpenSSL’})
Please see the logfile ‘/tmp/tmpfi4rmiuw/log’ for more details.
获取证书失败,请到 https://hijk.art 反馈

    跳跃者

    跳跃者 · 2020年2月15日 21:47

    你用的谷歌云吧?最简单的办法是升级到ubuntu 18.04,如果不方便请留言,我再给解决方案

头像

CD · 2020年2月15日 02:19

TypeError: from_buffer() cannot return the address of the raw string within a bytes or unicode or bytearray object
获取证书失败,请到 https://hijk.art

    跳跃者

    跳跃者 · 2020年2月15日 09:05

    从评论里找答案

      头像

      CD · 2020年2月16日 00:45

      抱歉,恕我愚昧。评论没有找到答案。是否是指的要升级到ubuntu 18.04
      现在是16.lts版本。
      如果是的话,麻烦也把帖子系统版本写上。让后来者不用走我这个坑。
      谢谢。

        跳跃者

        跳跃者 · 2020年2月16日 00:49

        这个现象只针对google云的16.04 lts版本,在github和本站都有人问过了。你如果不想换系统,这样解决:apt remove -y python3 python3-pip ; mv /usr/local/bin/pip3 ~/pip3.bak ; apt install -y python3 python3-pip lsb_release,然后再运行一键脚本

头像

111 · 2020年2月15日 02:06

v2ray.com/core/proxy/vmess/outbound: failed to read header > v2ray.com/core/proxy/vmess/encoding: failed to read response header > websocket: close 1000 (normal)
2020/02/15 02:05:59 tcp:127.0.0.1:53089 accepted tcp:m8.music.126.net:443 [proxy]
2020/02/15 02:06:01 [Warning] failed to handler mux client connection > v2ray.com/core/proxy/vmess/outbound: connection ends > v2ray.com/core/proxy/vmess/outbound: failed to read header > v2ray.com/core/proxy/vmess/encoding: failed to read response header > websocket: close 1000 (normal)
2020/02/15 02:06:02 tcp:127.0.0.1:53093 accepted tcp:cdn.52bz.la:443 [proxy]
2020/02/15 02:06:03 [Warning] failed to handler mux client connection > v2ray.com/core/proxy/vmess/outbound: connection ends > v2ray.com/core/proxy/vmess/outbound: failed to read header > v2ray.com/core/proxy/vmess/encoding: failed to read response header > websocket: close 1000 (normal)

    跳跃者

    跳跃者 · 2020年2月15日 09:07

    用伪装了没有?

    头像

    111 · 2020年2月15日 13:07

    用了,一切都设置的合适,网页也能打开,还有加后缀那个路径也能打开。一切正常,。就是上不了网,昨晚搞到12点多

      跳跃者

      跳跃者 · 2020年2月15日 14:11

      手机上试试

        头像

        111 · 2020年2月16日 13:33

        还是不行。。是不是cf域名不能用?但也没道理。。

          跳跃者

          跳跃者 · 2020年2月16日 14:04

          肯定不是,感觉是你配置错了

跳跃者

跳跃者 · 2020年2月13日 20:58

你们的服务器哪买的?github上有个人的报错和你一样,都是系统的pip环境有问题导致的
先运行这条命令:apt remove -y python3 python3-pip ; mv /usr/local/bin/pip3 ~/pip3.bak ; apt install python3 python3-pip,然后再重新运行一键脚本

    头像

    daqei · 2020年2月13日 21:04

    谷歌云的服务器

      跳跃者

      跳跃者 · 2020年2月13日 21:06

      好像是有点问题,你先试试吧

        头像

        daqei · 2020年2月13日 21:52

        大佬,执行命令后提示:

        系统版本: /dev/fd/63: line 360: lsb_release: command not found
        /dev/fd/63: line 24: lsb_release: command not found
        系统不是Ubuntu

          跳跃者

          跳跃者 · 2020年2月13日 21:56

          那你是啥系统啊?

        头像

        daqei · 2020年2月13日 22:03

        谷歌云 Ubuntu 16.04 LTS,运行脚本后提示获取证书失败,

        执行
        apt remove -y python3 python3-pip ; mv /usr/local/bin/pip3 ~/pip3.bak ; apt install python3 python3-pip

        后显示

        系统版本: /dev/fd/63: line 360: lsb_release: command not found
        /dev/fd/63: line 24: lsb_release: command not found
        系统不是Ubuntu

          跳跃者

          跳跃者 · 2020年2月13日 22:14

          先运行这个命令:apt install -y lsb-release,然后再执行一键脚本

        头像

        daqei · 2020年2月13日 22:39

        我换了个 19 的系统 ,问题已解决 ,谢谢

头像

daqei · 2020年2月13日 20:19

大佬,一直显示获取证书失败,已经换了好几个主机名

    跳跃者

    跳跃者 · 2020年2月13日 20:41

    贴详细错误信息

头像

xiaoyu · 2020年2月12日 19:39

ERROR: pyopenssl 19.1.0 has requirement cryptography>=2.8, but you’ll have cryptography 1.2.3 which is incompatible. Installing collected packages: pytz, distro, parsedatetime, pyrfc3339, ConfigArgParse, zope.interface, zope.proxy, zope.deferredimport, zope.deprecation, zope.event, zope.hookable, zope.component, mock, PyOpenSSL, requests-toolbelt, josepy, acme, certbot, ndg-httpsclient
Successfully installed ConfigArgParse-1.0 PyOpenSSL-19.1.0 acme-1.2.0 certbot-1.2.0 distro-1.4.0 josepy-1.3.0 mock-3.0.5 ndg-httpsclient-0.5.1 parsedatetime-2.5 pyrfc3339-1.1 pytz-2019.3 requests-toolbelt-0.9.1 zope.component-4.6 zope.deferredimport-4.3.1 zope.deprecation-4.4.0 zope.event-4.4 zope.hookable-5.0.0 zope.interface-4.7.1 zope.proxy-4.3.3

获取证书失败,请到 https://hijk.art 反馈

    跳跃者

    跳跃者 · 2020年2月12日 19:54

    github上已经回复了,去那讨论吧

头像

Mallissa · 2020年2月12日 16:50

一直是未解析怎么办,已经按照提示的方法改过了

    跳跃者

    跳跃者 · 2020年2月12日 17:18

    没设置对吧?ping一下看看ip地址对不对

      头像

      Mallissa · 2020年2月12日 18:10

      解决了,等一等就好了…….

头像

苏点点 · 2020年2月12日 15:54

Failed to install unzip. Please install it manually.
安装失败,请到 https://hijk.art 网站反馈
[email protected]:~#

    跳跃者

    跳跃者 · 2020年2月12日 16:13

    前面的信息呢?或者 apt install -y unzip,然后再试试

发表评论

电子邮件地址不会被公开。 必填项已用*标注